Username: Password:

Author Topic: What did I get?!?  (Read 1151 times)

Offline sopwith99

  • Newbie
  • *
  • Posts: 1
    • View Profile
What did I get?!?
« on: November 11, 2017, 04:34:51 PM »
I bought a WI14 guitar today, at least thats what it says on the truss rod cover.  All the images I found on the internet show a hard tail bridge but this one has a tremolo.  It has a transparent finish that shows some nice grain.  The serial starts with 0309xxxx so I guess it was made in 2003.  If anyone knows some details about this model I'd love to know more.


Offline Tony Raven

  • Sr. Member
  • ****
  • Posts: 904
    • View Profile
Re: What did I get?!?
« Reply #1 on: November 11, 2017, 06:44:04 PM »
The WI-14 only had a hardtail bridge. It's possible someone routed it out for a trem, though I'd be surprised they'd do this with the cheapest Idol. BlueBook says the 14 was built 2004-2010, but there's some "slop factor" in the numbering system so 2003 would not be impossible. The 14 was available in Walnut finish -- you don't say what the color is.

Trussrod covers can be changed.
M1SDL; XB-400 (natural), XB-400 (burg), XB-500 (teal); X-10, X-33; D46CESP, WCSD30SCE; BT-3, BT-4, BT-6, JB-80; WS-4; WI-66V; Lyon LCT24; OS Autoharps

resident troublemaker:

Offline shaulin

  • Sr. Member
  • ****
  • Posts: 475
    • View Profile
Re: What did I get?!?
« Reply #2 on: December 07, 2017, 02:42:28 AM »
a picture would help :)

The only Idols that keep popping up with a tremolo are the WI66V and the WI50V

'04 Washburn X50
'06 Washburn PI80
'07 Washburn N4
'08 Washburn WM526 (White)
'08 Washburn WM526 (Ferrari Red)
'09 Washburn WI568
'09 Washburn WI590