Username: Password:

Author Topic: WAshburn XB122 bad preamp  (Read 162 times)

Offline TeriCo

  • Newbie
  • *
  • Posts: 1
    • View Profile
WAshburn XB122 bad preamp
« on: November 11, 2017, 07:38:53 PM »
I have a Washburn bass XB 122 Bantam series. I recently replaced the output jack thinking this was the problem (popping like a MoFo and then dead silence. I can fool around with it and it'll work for a minute or two and then BAM! pooping and down in the water again). I took it  Guitar Center tonight and the guy told me that the preamp needs replacing, but eh dint; check the wiring inside, Anyone have a problem with the preamp on this particular bass and if so, what was a good replacement? Go easy on me- I am not an electronics whiz; I'm an English teacher :)   The serial number on the back metal plate reads: 0C05110863
If someone can walk me through posting pics I can post what the inside with preamp looks like.

Offline Tony Raven

  • Sr. Member
  • ****
  • Posts: 852
    • View Profile
Re: WAshburn XB122 bad preamp
« Reply #1 on: November 13, 2017, 01:04:34 AM »
Photos need to be placed at some online site, from which you can import htem with an [ img ] tagset.

Anyway, speaking as an actual guitar tech 8) the kid at the GC counter is NOT an authority.

If you get a "pop" then nothing, I'd suspect a break or short first, rather than the preamp. To me, sounds like a bad battery connection across the jack.

I have no idea what an XB-122 is.  ??? The 120 ended 2004. In any case, it's likely LONG gone & there's about zero chance of a factory replacement, seeing as the company has changed hands since. For me, there's little upside to reworking a $200 instrument except for he experience.

As the (happy) owner of an XB-400 & XB-500, a downside is that the mini-pots easily sieze up due to humidity. They need a shot of something like Caig DeoxIT to have a chance of working right.
M1SDL; XB-400 (natural), XB-400 (burg), XB-500 (teal); X-10, X-33; D46CESP, WCSD30SCE; BT-3, BT-4, BT-6, JB-80; WS-4; WI-66V; Lyon LCT24; OS Autoharps

resident troublemaker: http://forum.frugalguitarist.com/