Username: Password:

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Johnzim63

Pages: [1]
1
In case anyone is interested:  I finally had a luthier run down the problem and fix it for around $75.  Not sure exactly what caused the issue--he would not explain his alchemy--but it works great now.

2
Dammit, the loud static issue came back.   >:(

The dual output housing seems fairly generic:  XLR jack, 1/4" jack, & battery holder.  Anyone know where I can find one?

3
All three of my Exotic woods found a new home today.  :(    Just have to clean out some guitars.  That Zebra wood had good dread projection. I will miss them, but my other sound as good, now down to 9 guitars.  But got a new 2 channel 1200 watt amp for my pa.   in the next couple of weeks getting 2  x   15"   speakers to go with my 4  X  10" Crates.   Fill out my sound better.   now using a older Peavey 2 x 15  bass cab for my low end with a 120  x  300 watt monitors heads  for power.     Also just in case you do not know, unplug your jack to keep from running your batt down.    Tom.  :)  Almost forgot,  yes,  250.00   is almost like giving it away.  :)
Wow, that must be quite the Wall of Sound you're producing.

I finally got a small mirror to look inside for the preamp.  It's the red B-Band unit, which I think is the 2-pickup version.  I'm hoping that turning down the gain from the AST pickup will tame the major white noise that the guitar is sending out.  Otherwise I suppose I'll need a new preamp.  Or is it possible that remounting or replacing the pickups would resolve this issue?  Thanks again for your help!

4
John, welcome to the forum. I was told when plugging and unplugging my guitar I should always turn the volume off, both on the guitar and the amplifier. This will eliminate the cracking and also save your electronics. Also check for a looseness in the jack. Good luck. murph
Thanks, Murph.  That's good advice that I always follow:  If the amp I use doesn't have a standby switch, I always zero the master volume when plugging in or out.  This issue apparently was caused by some tiny bit of crap that got into the jack, since it was cured by a blast of cleaning solvent and a q-tip.  The fly has been extricated from the ointment....   :)

5
Welcome,  made in China in 2009.  Nice looking guitar. The SCE stands for solid top cut out electric. I cant see if the J stands for Jumbo or not. The DL is Deluxe, and the N is for Natural color wood finish.  As for the Master volume I don't know.      Tom.  :) As for the crack sound on plug in,  start off cleaning every thing,  that is always a good place to start, as for the end plug that is easy to change.  :) Here is a cut & paste from my 09 Washburn price list.  That guitar was not cheap. does not tell what electronics were. It is from the Cumberland series.  :)
Thanks, Tom; most helpful of you.  I sprayed a little auto brake cleaner into the 1/4 jack and swabbed with q-tips:  Problem solved!  Whew, that's a relief!!  My life is rarely so simple.   ???  ;D

It is a Cumberland Jumbo.  I got it for $250 with the original Washburn hardshell case!  I knew it was a steal, even if the pickup/preamp is WAY to microphonic.  I figure it would've been a good deal at $500.  So I may spend another $200 or so to get the right amplified sound.  Just sitting around playing it acoustically is like a dream; the fretboard is a joy to touch!
BTW:  Your zebra-wood D10 is amazing looking!  How does it sound?

6
I'm new to the board, so please forgive my ignorance.   :D  I recently acquired a J28SCEDL.  I love the nice bright acoustic sound; perfect for "church music".  But when plugged in it produces an ear-splitting CRACK when the 1/4" plug is rotated even the slightest bit.  Is this just a matter of cleaning?  This guitar hasn't been used much at all, so I'd be surprised if it was that simple.  I've swapped out the cable and the problem remains.  Thanks for any advice you can supply.

Also, can anyone identify this preamp with Taylor-esque controls?  I've NEVER seen an acoustic/electric with the master volume knob in the top.  Not 100% sure, but it looks factory-installed.

Lastly, any help decoding this serial number?  I'd like to know the year of production, and any other hidden gems.  Thanks!!


Pages: [1]